EQ2 Official Support for Windows XP Ending in June 2016

sheena

Divo
As mentioned in the Terrors of Thalumbra expansion, the minimum system requirements to run EverQuest 2 at this time is Windows 7 and we have not offered support for [previous] systems since it’s launch in 2015. While an older OS may have continued to function, after the first game update in June these may no longer be able to run the game in an optimal manner.

Please ensure you have reviewed the specifications here.

vi lascio il link al post di feldon per ulteriori info e/o chiarimenti
 
Alto