Problema Latency

Imoen

Super Postatore
Scusate se magari ci sono altri post simili ma non riesco a risolvere sto rognoso problema che mi porterà credo a non rinnovare anche se il gioco mi piae moltissimo.

Ma solo a me capita di avere ritardi assurdi nelle skill? mi spiego meglio... ok il gcd fa cagare ma quando sono in bg mi è praticamente impossibile usare le abilità. Parto con la prima e tempo di gcd e latency la seconda mi parte dopo 3/4 secondi sempre se parte. Pg che mi son davanti, vado per fare una skill alle spalle (tipo backstab per intenderci) e nulla, non parte per poi pensare "mha forse li vedo vicino a me ma son lontani" (allucinazioni pure :) )

La Latency me la da minimo a 100 con picchi anche a 200. Ho provato già ad eseguire i cambiamenti nelle impostazioni che erano proprio di WoW, le stringhe ecc ecc ma non funziona uguale.
Ora il problema ce l'ho solo io, dipende dalla linea (Alice) che ho, dal Computer (intel core duo a 2.66 8 giga ram ddr2 nvidia 6800 GT 1gb di ram) o da sti server del piffero che hanno su alla Bioware.
Per intenderci ho anche provato a giocare con risoluzioni cagose tipo addirittura 800:600 et simila ma il problema non cessa (quindi ho dedotto che poco centra il livello grafico)

Sono l'unico o anche altri hanno questi problemi?
E se magari qualcuno avesse qualche rimedio.....

Thx a tutti
 
Secondo me è un mix di fattori.



Io con Alice avevo 0 problemi,adesso ho infostrada e vengo kickato dal server almeno 4 volte al giorno,in una sessione variabile di circa 4/6 ore di gioco.



Grosso modo ho il tuo stesso hardware (scadente),la verità è che non sapremo mai qual'è il nostro problema.



Inutile dire che l'ideale sarebbe hardware aggiornato con la fibra di fastweb,ma temo dovremo accontentarci :trollface:
 

lehmus

Mito
Il discorso sulla qualità delle connessioni è molto soggettivo.
Certo Telecom non brilla per l'overbooking che effettua sulla propria banda passante, però dipende tutto da quanta gente nella tua zona è collegata al tuo DSLAM. Ergo ad alcuni può andare alla grande ad altri no.

Detto questo in effetti avere più di 100 ms di latenza, anche nelle situazioni di particolare carico sul server, è un pò tantino. Credo comunque che il tuo collo di bottiglia sia rappresentato dalla scheda video che è davvero troppo poco performante per quanto richiesto da SWTOR.
 

Imoen

Super Postatore
Mi hai acceso un lampadina :) ..... tanto un upgrade era un po che volevo farlo, il mio cruccio era se oltre quello potesse dipendere dalla linea ma a quanto vedo è questione di (passatemi il termine) culo :D

Grazie mille
 

mentalrey

Lurker
Confermo 2 cose
1) infostrada a milano, porta a circa 60/70 ms di ping, ma
in alcuni momenti durante il sabato o la domenica, da un ping piu' che utilizzabile
si passa improvvisamente a 1200/3200 con relativo kick dal server e situazione normalizzata
al rientro.

2) Client, Server e net code non permettono di giocare agevolmente con la configurazione sopra.
(l'ottimizzazione fa Cagher, come in pochi titoli)
Si forma un accumulo di dati che non vengono sempre scaricati
che nelle configurazioni con 2 giga riempie la ram e finisce
con il rallentare qualsiasi cosa, compreso il "quit" dal gioco, che ci mette una vita.
Il caching delle texture funziona abbastanza male gia' su una 9600GT con shader low
e texture medie,
figuriamoci sulla 6800
Un e8400 a 3 gHz a volte soffre la comparsa del companion dopo una missione
e l'overclock non risolve, sembra piu' una questione di numero di core.

Passando da quel tipo di configurazione ad un i5 2500 con 8 giga di ram,
e un'Nvidia 5600Ti, la questione del carico cpu scompare grazie ai 2 core in piu'
che hanno il tempo di gestirsi tutti gli I/O del sistema e gli altri servizi,
(Si vede che il client e' strutturato per caricare solo 2 cpu in realta')
l'accumulo in ram di materiale non scaricato dal client non si sente,
perche' gli 8 giga fanno abbondantemente da cuscino
e la scheda grafica gestisce molto meglio sia il caching delle texture
che tutte le altre geometrie.
Va da se' che si tratta di una configurazione sorabbondante
rispetto a quello che il gioco stesso dovrebbe richiedere
e che fa' da workaround all'attuale mal programmazione del codice,
sia lato client che lato server.

Rimane comunque il problema di infostrada e soprattutto
di chi prova a giocare utilizzando il Wi-Fi, che gia' da solo
crea delle fluttuazioni enormi sul ping.
 
Ultima modifica:
Rimane comunque il problema di infostrada e soprattutto di chi prova a giocare utilizzando il Wi-Fi,
che gia' da solo crea delle fluttuazioni enormi.


Ottima analisi che condivido.


Rientro nell'accoppiata infostrada+wifi e sospettavo che fosse tutto fuorchè ottima :trollface:



Purtroppo al momento non posso fare altrimenti,ergo,suki-suki :alone:
 

mentalrey

Lurker
Cavo Docet
ho un amico su a londra con un'ottima connessione da 30 megabit,
ma le coninquiline in Wi-Fi spesso lamentano dei buchi temporali nel servizio di rete
e pensano che sia andata giu' la linea,
lui invece collegandosi al router con il cavo, non ha mai quel problema.
 
Ultima modifica:

lehmus

Mito
Rimane comunque il problema di infostrada e soprattutto
di chi prova a giocare utilizzando il Wi-Fi, che gia' da solo
crea delle fluttuazioni enormi sul ping.
A prescindere dal provider che in Italia (tranne Fastweb-fibra) hanno tutti apparati obsoleti e quindi fanno cacare a spruzzo, giocare usando il Wireless è un grosso terno al lotto. Il consiglio che vi do, prima di provare a fare qualsiasi cosa, per vedere le reali performance del network...collegate il vostro PC alla rete con un cavo RJ45.
 

Mr_White

Lurker
A casa: NGI + cavo ethernet = zero problemi (ping 50-60ms)
A lavoro: Alice + Wi-Fi = qualche leggero ritardo (ping 80ms circa, non costante)
 

Kakashi4ever

Super Postatore
Io al momento ho Alice ma sto per fare il passaggio ad Infostrada. Ne ho cambiati molti di operatori, 3-4, ma la situazione non è mai cambiata. Sempre sui 70-90ms. Ogni tanto qualche piccolo balzo sopra i 100 ma è raro. Ah, sto in wi-fi, ma devo provare col cavo a vedere come va.
In ogni caso in bg ora non ho più molti problemi; sarà anche il pc nuovo, ma su 10 bg ho avuto qualche problemino all'ultimo che ho fatto (i7@2.2Ghz con booster fino a 3.3, 8GB di RAM, nVidia GeForce 540M da 2GB di memoria dedicata).
 

mentalrey

Lurker
non penso che avrai un sostanziale miglioramento nel Tempo di ping, ma sicuramente usando il
cavo eviti gli sbalzi assurdi che ha il Wi-Fi.
 

andrea691

Super Postatore
Ragazzi non e un problema di conessione e di lag,e un problema di delay delle spell e lo hanno tutti,se andate a leggere il forum ufficiale ci sono già dei post dei dev che dicono che sono a conoscenza del problema e lo risolveranno con le prossime patch..quindi ragazzi non troppi allarmismi il gioco e uscito da nemmeno un mese,dategli tempo di risolvere sti problemi..
 
Alto